ELMoEmbeddingsのときはallennlp==0.9.0

NLPフレームワークのFlairでELMoの言語モデルを使おうとすると、from flair.embeddings import ELMoEmbeddingsをして関数を呼び出す必要があるのだが、allennlpがインストールされていない、もしくは、バージョンが異なると下のような警告文かエラーが発生する。

2021-05-17 23:50:19,400 ----------------------------------------------------------------------------------------------------
2021-05-17 23:50:19,400 ATTENTION! The library "allennlp" is not installed!
2021-05-17 23:50:19,400 To use ELMoEmbeddings, please first install with "pip install allennlp==0.9.0"
2021-05-17 23:50:19,400 ----------------------------------------------------------------------------------------------------

ここにも書いてある通り、バージョン0.9.0のallennlpをインストールして再度コードを動かす必要がある。

Pocket